←  Technical Questions

nanoCAD forum

»

Dimensions between model and paper space

TeaMan's Photo TeaMan 11 Sep 2021

I figured out how to set up a paper space and think I figured out how to make it work. I'm having a problem with dimensions though. I created the drawing in model space using Architectural units and Architectural angles. For me it was a little complicated. It's drawn 1:1 in model space. I created a new paper space I gave my own name and set it up for my printer, and tabloid. I then set it up for inches which changed to 1" = 25.4 and changed the numbers on the outside of the space to inches being 10.77 and 16.77. I set the orientation to Landscape.

Now the problem. If I look at one of my outside lines on my drawing it is 169'-11 3/16" long which it should be. I created a rectangular view port in Model space and chose the outside of what I will need to print, chose the paper space I wanted to put it on from the list, then clicked OK. It then asks to input or choose the scale. I first tried to use the scale of <Paper><1.0000>:1 and the drawing was way too large for the paper space as I suspected. I backed out of the command and created a rectangular viewport with scale of <Paper><1.0000>:.1 or 1/10th the size, which was almost the exact scale to make it fit properly. I went into my paper space and clicked on the dimension command and placed a dimension on the line mentioned above and it came up as being 16'-11 15/16" which I suspect is pretty much 1/10 of what it should be. How do I get the dimensions in my paper space to be the proper size? The other problem is the dimensions in paper space are very large compared to the few I have placed on the drawing in model space. How do I make them be the proper size for the paper space?

Hopefully this makes sense.

Ed
Quote

TeaMan's Photo TeaMan 11 Sep 2021

This is what I figured out so far.

I tried to go to my paper space which is scaled 1:0.1 or 1/10 and dimensioned a line. The physical size of the dimension is 10 times the size and the number or length of my line is 1/10 of what it should be. I clicked dimension and in inspector changed the scale to 10:1 which makes it appear about the right size, then the measurement to 1:10, the opposite of the scale in the inspector window, and the dimension now matches the one I get in my Model view. So, this seems to work. I then tried to figure out how to change the dimension style in the paper view to be scaled to match what I have in model view. I first tried to go into my paper view, clicked dimension from the menu, dimension style, modify, and under Primary Units, put .1 in for scale factor and checked the box to apply to layout dimension only. Clicked OK, then close. I then pulled a dimension on the same line and it was again the same dimension as before being 1/10 of what it should be as if nothing happened. I reopened dimensions, dimension style, modify and primary units, and the value of .1 was no longer there and the check box to apply to the layout dimension only was no longer checked. It didn't appear to save my edit. I thought maybe it didn't like me entering .1 for scale, so I clicked the pull down arrow and chose one of the values, checked the box to apply to layout and clicked OK then close. I pulled a dimension with the exact same result. I opened dimension style and looked under primary units and it was again back at default.

I thought maybe this has to be done in model space, so I tried it there. I got the same result when I went back to paper space. I'm at a total loss as to why I can make it work for a single dimension in inspector, but can't make it work for all dimensions in paper view.

I considered doing all dimensions individually, but it's a bit messy because it's hard to get the spacing to come out nicely since the dimension is starting out at 10 times the size, then when scaled down, is now in a different place than the original that was 10 times the size. Some work has to be done each time to get it so it looks OK. For the number of dimensions I have to do, it would be very tedious. The only other work around is to dimension the model space instead and let them come across with the drawing into paper space which may be my best work around for now.

I'm hoping someone will recognize what I'm doing wrong so I can fix it.

Thanks,
Ed
Quote

Hellen_V's Photo Hellen_V 13 Sep 2021

Hello Ed,
try to change this setting in PARAMS dialog:
Quote

TeaMan's Photo TeaMan 07 Oct 2021

Thanks Helen, both scale text and scale dimension are set to "Yes" in Params. I'd assume that would be if the dimension and any text was done in model space, then scaled to paper space correct? I was attempting to dimension the drawing in paper space on my sheet. When I did this, the dimensions were huge, basically looked like they were unscaled with respect to the drawing in model space, or maybe better said, were at the scaling of model space which is 10 times the scale of my paper space. My work around is to do all dimensioning in model space. My drawings are not complicated, so I can add or remove dimensions as needed, but it would be more convenient to have multiple paper spaces and be able to add only dimensions to the ones I want, so I'm able to highlight something specific. For instance, to dimension the outside perimeter in one paper space only, and then internal dimensions in another so the dimensions don't run together. One could be the outside plat map, and another internal details.

Maybe I'm mis-understanding. Maybe I should make both of them "no" instead of "Yes"?

TeaMan
Quote

Hellen_V's Photo Hellen_V 11 Oct 2021

Hi Ed,
do you use nanoCAD 5 or Plus/Pro? Do you work in measurement scale or symbol scale? What is its value?
Quote

TeaMan's Photo TeaMan 13 Oct 2021

Hi Helen, I'm using NanoCad 5. Before your last post, I didn't know what measurement scale or symbol scale were. I looked them up under help and it says scale is shown on the status bar. I don't see this on my screen anywhere. I must be missing something here. It does say in help that M1:1 would be 1mm scaled to 1 unit on the drawing. Since I'm in Feet and Inches, what would I put then? The other issue that is confusing, is in my explanation further below where I say I type the scale of .1, it used to prompt me for that, and now it doesn't, but I know this is where I should type it, so I do that. The last command line prompt I get is: "specify viewport first corner", here I click the lower left corner. The command line doesn't change, so I click the upper right corner. After I click both corners I get a pop up on the screen to choose the layout from a list, I click the one I explain below for my printer, then click OK, I still only see the "select viewport first corner" on the command line. If I hit my enter key, I get Scale: <paper><0.100000>:. I suspect this is because it's what I put in the last time I created a viewport. If rather than hit enter, I put a different value, it will use that value for the scale instead. I'm just not being prompted on the command line for it anymore. I do remember being prompted for each step at one time though.

Below is how I'm creating a viewport, and how my model space scale is set up.

What I do in model space is go into units and set it to Architectural with precision to 1/16". Insertion scale is set to feet. Then for the layout, I right click the bottom ribbon where it has tabs for model space and the 7 layouts that are default in NanoCad, and create a new Layout. I renamed it to my printers name then right click it and pick page setup. I click edit on the pop up, then choose my printer from the list of printers, and since it can print 11"X17" I choose tabloid, landscape and Layout for plot area and save it.

Next I go back to my model space where units are set to Architectural with precision of 1/16" and insertion scale set to feet, and go to the menus at the top of the screen, click View, Viewports, Rectangular. My command line then has RE on it, so I then hit enter. My command line then says "Specify Viewport first corner.:" I click the bottom left corner, then click the top right corner. I'm then prompted for the layout I wish to use. I choose the one I created with my printers name. I then type .1 for scale and hit the enter key. Note, the command line still says "Specify Viewport first corner.:" After I type .1 for the scale, the screen changes to the Layout I created for my printer and the one I chose when it prompted me for a layout. I then see a cursor with rectangle around it where the rectangle moves around the screen when I move my mouse. I center this on the border for the layout I created and click my left mouse button. The viewport I chose in the model space is placed in the layout. I'm not sure why I'm not getting the prompts anymore, but I've done it enough times to memorize the steps.

Now when I go to my layout and click on any of the dimensioning icons from NanoCad and create a dimension, the dimension text is very large and the dimension value is not correct, meaning for a line that is 64 feet long, the dimension in the layout is 6'-4 13/16" long. It is1/10 of what it should be which is what I had to scale the rectangle viewport in model space to fit into my layout which is 11"X17". It makes sense that the viewport is scaled by 1/10 but I'm not sure how to make the dimension take the scaling of the drawing in model space. Also the size of the dimension text is about 10X. It's hard to tell how large the text is, but it could easily be 10 times the size of the dimensions that I did in model space that came to the layout with the viewport.

I suspect I'm missing something simple, just not sure what that is. It could be measurement scale and symbol scale, but I'm not sure where the status line is to find them. Also, I may need to start from scratch again because I've tried so many different things to get lines to draw correctly and arcs as well as trying to figure out how to do layouts and viewports. Maybe just too many changes to this file could be causing the prompts to not work like they once did.

I could PM you with the actual drawing I have if that would help. It's still rough, but I'm trying to work out each piece before I refine it further and add more detail.

Thanks
Ed
Quote