Jump to content


Save not working

save dxf file save as

4 replies to this topic

#1 ash ash

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 02 April 2024 - 11:08 AM

Hi

Every time I try to save a file as a DXF if i change the file name "example" and click save, NanoCAD will save it as "example." which saves it as a "FILE" and not a ".DXF"

I think it is a similar issue to this thread https://forum.nanoca...-dwg-extension/

where it was recommended to "try to clear registry, it may solve the problem." What do i delete in the registry to fix this?

I am running NanoCAD V5 on Windows 10. Have been using it for years, the problem only started today.

#2 Artemio

    Advanced Member

  • Administrators
  • 321 posts

Posted 04 April 2024 - 07:15 PM

Hello,
I'd recommend first - to reboot PC, then check if there is no updates for your version of Win10.
This problem isn't related to nanoCAD issues and might be solved with Window10 new update patch.
Cleaning the registry doesn't seem to be the solving if I'm not mistaken.

Also one of possible solutions (definitely not the best one though) is to write extension to your file manually.

#3 ash ash

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 05 April 2024 - 08:41 AM

View PostArtemio, on 04 April 2024 - 07:15 PM, said:

Hello,
I'd recommend first - to reboot PC, then check if there is no updates for your version of Win10.
This problem isn't related to nanoCAD issues and might be solved with Window10 new update patch.
Cleaning the registry doesn't seem to be the solving if I'm not mistaken.

Also one of possible solutions (definitely not the best one though) is to write extension to your file manually.

Thanks for the reply.

The machine had Automatic Updates turned off so it had never received an update, so that could not of been the cause of the problem. However i did fully update the machine to see if it fixed the issue, unfortunately it did not.
Yes, writing the extension manually is the workaround i have been using. Manually adding the extension after saving works, also just typing .dxf at the end of your file name during the saving process works however it still adds a period at the end of the file ("example.dxf.) but windows at least recognises it as a .DXF and allows it to be opened as normal.

I'll leave some more information in case it helps debugging for anyone in the future;
Other programs have no problem saving a .DXF, Just Nanocad 5.
I also tried uninstalling NanoCAD 5 and deleting the residual files in Program Files + Appdata as well as cleaning the Registry, Then re-installing and re-activating NanoCAD 5 from a fresh install file but the issue is still there.
The issue is specific to this machine, the same licence & version of NanoCAD 5 works fine on a different computer running the same build of Windows 10.

If i ever fix it i will update this thread.

#4 Artemio

    Advanced Member

  • Administrators
  • 321 posts

Posted 06 April 2024 - 11:12 AM

Thanks for your promise to share the way you fix this, that would be really interesting and might be helpful.

This issue doesn't seems related to nanoCAD, but for PC mostly.

When you deleted nanoCAD, you cleaned Program Files, AppData and registry, but there is one more place to be cleaned for next clear installation: ProgramData.

Full deinstallation is:

1. Uninstall program via Control Panel.
2. Check and delete folder with NanoCAD files in: C:\Program Files\Nanosoft AS\
3. Check and delete folder with NanoCAD files in: C:\ProgramData\Nanosoft AS\
4. Check and delete folder with NanoCAD files in: C:\Users\<user name="">\AppData\Roaming\Nanosoft AS\
5. Call REGEDIT in command line and check if this brunch is clean: HKEY_CURRENT_USER\SOFTWARE\Nanosoft AS
* (note that ProgramData and AppData might be hidden in Windows)

#5 Dsw

    Member

  • Members
  • PipPip
  • 15 posts

Posted 06 April 2024 - 06:59 PM

@ash I don't know is this can help you, but this is the registry path where are saved informations about dxf/dwg file extensions and more...

"HKEY_CURRENT_USER\SOFTWARE\Nanosoft\nanoCAD Int\5.0\Profile\IO\Formats"
or
"HKEY_CURRENT_USER\SOFTWARE\Nanosoft AS\nanoCAD Int\5.0\Profile\IO\Formats"

If you don't know what you need to check or change, see attached image.

Attached Thumbnails

  • Attached Image: Immagine 2024-04-06 205434.png






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users