Jump to content


Dimensioning within viewports

Dimension scale

7 replies to this topic

#1 jlk

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 18 February 2015 - 10:36 PM

Created objects in model space then created several viewports in layout space at different scales.
When I dimension objects in the viewports created in layout space, the dimensions are incorrect and don't scale to the viewport scale.
Is there a setting for this?
JLK

#2 Hellen_V

    nanoCAD Team

  • Members
  • PipPipPip
  • 742 posts

Posted 19 February 2015 - 07:18 AM

There are two ways:
1. dimension objects when viewport is not active
2. in active viewport change Measurement scale according to viewport scale (select Measurement scale in the bottom right corner and then select the desired scale).
Go for nanoCAD Plus 10 now!
New interface, improved and accelerated drawing process, support for dwg2018 format. You will like new version!
Free trial license is available here: https://nanocad.com/.../plus/download/

nanoCAD Support Team
support@nanocad.com

#3 jlk

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 19 February 2015 - 04:13 PM

Thanks for the reply.
It would be great to use your first option, dimension objects when viewport is not active, however that is not working for me, would prefer this method.
I am testing NanoCad x64 Plus en 6.0.
Have any ideas why this method does not work?
Thanks, JLK

#4 Hellen_V

    nanoCAD Team

  • Members
  • PipPipPip
  • 742 posts

Posted 20 February 2015 - 06:51 AM

It should work correctly.
Let's check your actions:
1. draw rectangle in Model space: (0,0 - 10,10)
2. create viewport in Layout, scale is 10:1
3. check that viewport is not active
3. set the dimension. It should show 100 (see image below)
Attached Image: scale.png
Go for nanoCAD Plus 10 now!
New interface, improved and accelerated drawing process, support for dwg2018 format. You will like new version!
Free trial license is available here: https://nanocad.com/.../plus/download/

nanoCAD Support Team
support@nanocad.com

#5 jlk

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 21 February 2015 - 10:13 PM

Once again, thank you for your reply!
Followed the steps you outline and that worked.
What I though would happen is this:
Since I do architectural drawings the unit measure is feet and inches.
When I draw a rectangle at 10' x 10' in model space, then create two viewports in layout, first viewport at 1/8" =1'-0" and second viewport at 1/4" = 1'-0".
With viewports not active, measure each and they should measure the same 10 feet x 10 feet, they don't.
One viewport is 10' x 10' and the second 20' x 20'.
Unless I don't understand the concept, both viewports should show the same measurement regardless of its appearance is size within the viewport.
Thanks, JLK

#6 Hellen_V

    nanoCAD Team

  • Members
  • PipPipPip
  • 742 posts

Posted 24 February 2015 - 11:42 AM

I'm sorry, I understood you wrong.
You should change Measurement scale for every dimension according to viewport scale:
select dimension and make its Measurement scale inverse to the viewport scale.
Go for nanoCAD Plus 10 now!
New interface, improved and accelerated drawing process, support for dwg2018 format. You will like new version!
Free trial license is available here: https://nanocad.com/.../plus/download/

nanoCAD Support Team
support@nanocad.com

#7 Ronbu

    Newbie

  • Members
  • Pip
  • 6 posts
  • LocationLevin, New Zealand

Posted 23 May 2015 - 02:42 AM

View Postjlk, on 21 February 2015 - 10:13 PM, said:

When I draw a rectangle at 10' x 10' in model space, then create two viewports in layout, first viewport at 1/8" =1'-0" and second viewport at 1/4" = 1'-0".
With viewports not active, measure each and they should measure the same 10 feet x 10 feet, they don't.
One viewport is 10' x 10' and the second 20' x 20'.

I'm another newbie here (but not to CAD use) and I have to agree with JLK.
No matter at what scale an object is represented in a layout viewport it should be possible to dimension that object to show its real world dimensions as the default for the layout.
After all in most cases the layout is a 1:1 representation of what the user needs to print to paper.
When that does not happen then the advantages associated with dimensioning in the layout are somewhat negated.
Is there a setting that will turn off the current (apparently nanoCAD default) action of multiplying the real-world value of a dimension by the scale factor of the viewport in which an object is represented?
[User of nanoCAD v.5.0 on Windows 7/64 Home Premium.]
70 plus and still finding plenty to learn.

#8 Ronbu

    Newbie

  • Members
  • Pip
  • 6 posts
  • LocationLevin, New Zealand

Posted 23 May 2015 - 10:18 AM

View Postronnbu@gmail.com, on 23 May 2015 - 02:42 AM, said:

Is there a setting that will turn off the current (apparently nanoCAD default) action of multiplying the real-world value of a dimension by the scale factor of the viewport in which an object is represented?

Since my previous post I have found that when dimensioning a model space entity through a viewport in paperspace (with the viewport inactive):

(a) Rather than multiplying by the viewport scale factor as I first thought, nanoCad seems to use, by default, the 1:1 paperspace dimension of the entity to determine the dimension value of a dimension that is placed on any entity visible in paperspace – even when originally drawn in model space. If scaling has been used to allow the viewport to properly show its content, the resulting dimension for entities of the model will be the actual size of the paperspace representations of those entities rather than their real-world size.

( B) The dimension value may be corrected in this case by telling nanoCad the scale of the viewport* by RIGHT-CLICK on the dimension > LEFT-CLICK the magnifier (on the bottom line of the resulting window) > SELECT the appropriate viewport scale (from the scale list that results) > SELECT OK. The dimension should now show the real-world dimension of the entity.
Further dimensions can now be correctly added to that, and any other identically scaled, viewport until a new scale setting has been introduced.

© It is also possible to preset the scale value for any viewport of different scale from that last used by selecting the SCALE button (M#:#) at the lower right of the workspace and selecting a scale from the list there.

[* It seems odd that this is necessary since nanoCad is already reporting that scale for the viewport in the INSPECTOR. It seems that a toggle allowing optional use of that scale in this case would make better sense – but maybe I have missed something that already exists???]
[User of nanoCAD v.5.0 on Windows 7/64 Home Premium.]
70 plus and still finding plenty to learn.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users