Jump to content


Mouse wheel zoom

mouse wheel zoom gui

10 replies to this topic

#1 Andrzej Weremko

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 06 February 2014 - 01:12 PM

Hello!
Firstly, I'd like to thank for NC (it's really a good SW).

Is there a possibility to change the action of mouse wheel from scroll to a zoom?

#2 Hellen_V

    nanoCAD Team

  • Members
  • PipPipPip
  • 750 posts

Posted 07 February 2014 - 08:05 AM

Hello, Andrzej,
Welcome to nanoCAD!

Are you using unusual mouse? The mouse wheel zooms by default in nanoCAD.
Try to change the settings of mouse in a Control Panel.
Go for nanoCAD Plus 10 now!
New interface, improved and accelerated drawing process, support for dwg2018 format. You will like new version!
Free trial license is available here: https://nanocad.com/.../plus/download/

nanoCAD Support Team
support@nanocad.com

#3 Andrzej Weremko

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 07 February 2014 - 02:10 PM

It's just a HID 5 button mouse (L+R+M +Back+Forward) + 1xScroll, A4Tech X-748K ("Oscar"), but all my mice ("mice"?) really do the same - isn't it just a little setting in Windows Registry or something? I have a Polish language version of Windows 7, and English NC (my Russian is getting better and better though).

#4 Hellen_V

    nanoCAD Team

  • Members
  • PipPipPip
  • 750 posts

Posted 10 February 2014 - 10:43 AM

I suppose, that it's a mice settings.
Tick the "MS-IntelliMouse compatible mode" in the Control Panel -> Mouse -> Wheel, it should help you.
Go for nanoCAD Plus 10 now!
New interface, improved and accelerated drawing process, support for dwg2018 format. You will like new version!
Free trial license is available here: https://nanocad.com/.../plus/download/

nanoCAD Support Team
support@nanocad.com

#5 Andrzej Weremko

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 13 February 2014 - 04:22 PM

Hmm I don't have such an option (that's windows 7 :( )I've got only horizontal or vertical scroll speed (lines per roll).

#6 Hellen_V

    nanoCAD Team

  • Members
  • PipPipPip
  • 750 posts

Posted 14 February 2014 - 08:42 AM

Well...
Try to delete the drivers of mouse. Also try to exclude the Oscar from AutoPlay in Control panel.
Go for nanoCAD Plus 10 now!
New interface, improved and accelerated drawing process, support for dwg2018 format. You will like new version!
Free trial license is available here: https://nanocad.com/.../plus/download/

nanoCAD Support Team
support@nanocad.com

#7 Andrzej Weremko

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 14 February 2014 - 12:59 PM

I don't have Oscar software installed; my drivers are:
Touchpad:
mouclass.sys, ver. 6.1.7600.16385 from 2016-06-21
i8042prt.sys, ver. 6.1.7600.16385 from 2016-06-21

USB mouse (any):
mouclass.sys, ver. 6.1.7600.16385 from 2016-06-21
mouhid.sys, ver. 6.1.7600.16385 from 2016-06-21

I also tried changing Windows locale and region - to no avail

#8 Hellen_V

    nanoCAD Team

  • Members
  • PipPipPip
  • 750 posts

Posted 14 February 2014 - 01:18 PM

Try the following:
Open Tools - Options and set "2" in Scroll Settings - Mouse Wheel scale factor
Go for nanoCAD Plus 10 now!
New interface, improved and accelerated drawing process, support for dwg2018 format. You will like new version!
Free trial license is available here: https://nanocad.com/.../plus/download/

nanoCAD Support Team
support@nanocad.com

#9 Andrzej Weremko

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 14 February 2014 - 02:53 PM

It didn't work, even didn't change the scroll speed.PS. my NC version is 5.0.2520.1471 (I didn't mention that).

#10 SevaM

    Admin

  • Administrators
  • 225 posts

Posted 17 February 2014 - 01:54 PM

Hello Andrzej,

please, try how your wheel works in maps.google.com. Is it zoom or scroll?

#11 Andrzej Weremko

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 17 February 2014 - 08:36 PM

It's a zoom.
Then again, is it correlated that my zoom (via ZOOMD) is.. sluggish / slow (on all possible HW OGL/DX settings)?





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users