Jump to content


random change of Z coordinate

move

4 replies to this topic

#1 Vic Phillips

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 19 May 2020 - 05:47 PM

I am a 30 year+ user of AutoCAD, and recently DL'ed nanoCAD Free for occasional home use, in making simple 2D plans for woodworking projects. It's very familiar in most respects, but I I have run into a problem that is causing much trouble. It seems that random drawing objects will change the Z coordinate by a huge factor, for no apparent reason. It just isn't possible to do this in error, or unknowingly. As close as I can determine, it happens most frequently with closed polylines created with the RECTANGLE command. I am on the World UCS ins Model space, and no matter how carefully I create these rectangles, confirming that all vertices are on "0" elevation, if I copy, rotate or simply move the rectangle, the Z coordinate will change, by as much as 4000 dwg units. This also happens more randomly with single lines, and only on one endpoint. With any drawing element, If I access the properties and manually change the elevation back to "0," the whole object just disappears.
Is the installation corrupted? Is there some bug? Any help would be welcome!

#2 pguimber

    Advanced Member

  • Members
  • PipPipPip
  • 131 posts
  • LocationFrance - Maine et Loire

Posted 20 May 2020 - 05:09 AM

Hello,
a file for see the problem ?

Cordialy
Patrick

#3 Vic Phillips

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 21 May 2020 - 04:51 PM

This one. Simple 2d layout, for my build use, not for presentation.

#4 Vic Phillips

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 21 May 2020 - 04:52 PM

Sorry. Try again.

Attached Files



#5 pguimber

    Advanced Member

  • Members
  • PipPipPip
  • 131 posts
  • LocationFrance - Maine et Loire

Posted 22 May 2020 - 05:30 AM

Hello Vic,
Sorry, not possible to reproduce the bug on my computer :unsure: .
Idon't see where is the bug

When this problem occurs, a regeneration of the drawing gives what

A file with objects that have changed Z?
to see if this change is saved and if it allows me to see this problem: "If I access the properties and manually change the elevation back to "0," the whole object just disappears."

Best regards
Patrick





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users